Car won't boost just removed from hibernation - 3000GT/Stealth International Message Center
3000GT/Stealth International 3000GT/Stealth International
 

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   3000GT/Stealth International Message Center > Modifications and Technical Support > Engine - Turbo


3SI.org is the premier Mitsubishi 3000GT Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 06-12-2017, 07:42 PM   #1 (permalink)
Forum Member
 
Join Date: Jan 2017
Canadianboost is an unknown quantity at this point
Feedback Score: 0 reviews
Default Car won't boost just removed from hibernation

92 stealth won't boost past 5psi
40000kms stored for 10 plus years
Only recently driven for 40kms
New fuel filter
New coils and wire
New plugs
Timing adjusted to 5 with timing wire grounded
Leak tested found some and fixed
Turbos spin freely
Tried stock and manual boost controller
Both wastegates move when air pressure added
Aluminum y-pipe intake with hks Bov

Any other ideas/experiences appreciate
Canadianboost is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-12-2017, 08:19 PM   #2 (permalink)
Super Duper Mod
 
lawdogg's Avatar
 
Join Date: Jul 2003
Location: San Francisco
Drives: deals
lawdogg Level 3lawdogg Level 3lawdogg Level 3lawdogg Level 3lawdogg Level 3lawdogg Level 3lawdogg Level 3
Feedback Score: 109 reviews
Default Re: Car won't boost just removed from hibernation

Factory boost gauge or aftermarket?

Assuming aftermarket. What happens if you pull the wastegate hose? That'll get the boost controller out of the equation. 5psi is around wastegate pressure of 6psi (iirc).
__________________
Quote:
Originally Posted by GTO Assassin View Post
Quote:
Originally Posted by ray pampena View Post
Cant we all just smile and get along?
No!
lawdogg is offline   Reply With Quote Quick reply to this message
Old 06-12-2017, 08:34 PM   #3 (permalink)
Forum Member
 
Join Date: Jan 2017
Canadianboost is an unknown quantity at this point
Feedback Score: 0 reviews
Default Re: Car won't boost just removed from hibernation

Aftermarket gauge

I've tried unhooking the wastegates and no runaway boost still the same
Canadianboost is offline   Reply With Quote Quick reply to this message
 
Old 06-12-2017, 08:39 PM   #4 (permalink)
Super Duper Mod
 
lawdogg's Avatar
 
Join Date: Jul 2003
Location: San Francisco
Drives: deals
lawdogg Level 3lawdogg Level 3lawdogg Level 3lawdogg Level 3lawdogg Level 3lawdogg Level 3lawdogg Level 3
Feedback Score: 109 reviews
Default Re: Car won't boost just removed from hibernation

Huh, and it runs with the MAS plugged in? What happens if you unplug the MAS? Seems like a massive boost leak, or a massive exhaust manifold leak, or a pair of seized wastegates which you checked. Are they stock turbos?
lawdogg is offline   Reply With Quote Quick reply to this message
Old 06-12-2017, 09:31 PM   #5 (permalink)
Forum Member
 
Join Date: Jan 2017
Canadianboost is an unknown quantity at this point
Feedback Score: 0 reviews
Default Re: Car won't boost just removed from hibernation

I will test for Boost​ leaks again. When I tested I did both turbos tracts seperatly with no y-pipe should I do it thru the mas instead and plug it at the TB.
Also what will.happen if I unplug the MAS what r you thinking​ it's reaction will be. Am I just testing MAS off at idle or driving?
Canadianboost is offline   Reply With Quote Quick reply to this message
Old 06-12-2017, 10:13 PM   #6 (permalink)
Forum Member
 
StealthyRT's Avatar
 
Join Date: Mar 2013
Location: Michigan
Drives: 92 RT/TT & 91 SL
StealthyRT is an unknown quantity at this point
Feedback Score: 10 reviews
Default Re: Car won't boost just removed from hibernation

If you unplug the MAF it will go into limp mode, if it runs okay, then your MAF is shot.

What happens when you hit 5psi?

Does it buck, and misfire?

You should be leak testing right after the MAF, and pressurize the whole system to make sure you find any leaks.
__________________
-Shane
------------------------------------------------------------
"$1,000,000.00 ONE MILLION DOLLARS. TURBO LEGENDS NEVER DIE." -alldaysteve1

1992 Stealth TT
Rebuilt Motor, Test Pipe. Obx Down Pipe, Gutted Pre-Cats, Poly Mounts, EGR delete, Walbro 255, Greddy type-s, Profec B spec II, Tein S-Tech Springs, 3sx Pre Turbo Pipes, B&M 11x10 Oil Cooler, 99 Lifters, Forged 93 Crank, 3sx lightweight pully, GM 3" maf w/ MAFT, 98sl Flashable ECU, 550cc Delphi Injectors

1991 3000gt SL ATX swapped to MTX
Rebuilt Motor, 99 Lifters, Prothane Engine mounts, Test Pipe, 3SX STS, ̶t̶r̶a̶n̶s̶l̶a̶b̶ ̶s̶h̶i̶f̶t̶k̶i̶t̶, TT Plenum, intake resonator delete, 3SX Light Weight Flywheel, TT 1G Brakes, Clutch Damper Delete, Eibach 2810.140 ECS Lowering Springs

2003 SVT Focus - SOLD FINALLY

WTB:
StealthyRT is online now   Reply With Quote Quick reply to this message
Old 06-12-2017, 10:27 PM   #7 (permalink)
Forum Member
 
Join Date: Jan 2017
Canadianboost is an unknown quantity at this point
Feedback Score: 0 reviews
Default Re: Car won't boost just removed from hibernation

It actually runs really smooth all the way to redline even on boost. So I will boost even without MAS.
So I do or don't plug at the TB for pressure test?

Turbos are stock...

Last edited by Canadianboost; 06-12-2017 at 10:47 PM.
Canadianboost is offline   Reply With Quote Quick reply to this message
Old 06-13-2017, 08:46 AM   #8 (permalink)
Forum Member
 
StealthyRT's Avatar
 
Join Date: Mar 2013
Location: Michigan
Drives: 92 RT/TT & 91 SL
StealthyRT is an unknown quantity at this point
Feedback Score: 10 reviews
Default Re: Car won't boost just removed from hibernation

Quote:
Originally Posted by Canadianboost View Post
It actually runs really smooth all the way to redline even on boost. So I will boost even without MAS.
So I do or don't plug at the TB for pressure test?

Turbos are stock...
If its running smoothly its probably not a boost leak or MAS... Very strange though, maybe you have a plugged cat?
StealthyRT is online now   Reply With Quote Quick reply to this message
Old 06-13-2017, 11:58 AM   #9 (permalink)
Forum Member
 
Join Date: Jan 2017
Canadianboost is an unknown quantity at this point
Feedback Score: 0 reviews
Default

Cat looked visibly good mostly white but I could hollow it out if that might make a difference
Canadianboost is offline   Reply With Quote Quick reply to this message
Old 06-13-2017, 01:41 PM   #10 (permalink)
^^My name is April^^
 
dbest671's Avatar
 
Join Date: May 2008
Location: Tennessee
Drives: Spyder VR4/SRT8/CTSV
dbest671 Level 2dbest671 Level 2dbest671 Level 2dbest671 Level 2dbest671 Level 2dbest671 Level 2
Feedback Score: 92 reviews
Default Re: Car won't boost just removed from hibernation

Quote:
Originally Posted by Canadianboost View Post
It actually runs really smooth all the way to redline even on boost. So I will boost even without MAS.
So I do or don't plug at the TB for pressure test?

Turbos are stock...
do not plug the TB
dbest671 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  3000GT/Stealth International Message Center > Modifications and Technical Support > Engine - Turbo

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the 3000GT/Stealth International Message Center forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Free email addresses do not work(yahoo, hotmail, gmail,...)
We are currently being blocked by AOL so any AOL based address may not work(aol.com, aim.com, netscape.net, cs.com)
Email Address:
Real Name(First & Last)
(Required/Hidden)
Mailing Address(Street)
(Required/Hidden)
City
(Required/Hidden)
State
(Required/Hidden)
Zip
(Required/Hidden)
Country
(Required/Hidden)

Log-in

Random Question

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 09:06 AM.



vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
 

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Search Engine Optimization by vBSEO 3.3.2