Broken speedometer on 92 VR4 - 3000GT/Stealth International Message Center
3000GT/Stealth International 3000GT/Stealth International
 

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   3000GT/Stealth International Message Center > Modifications and Technical Support > Engine - Turbo

3SI.org is the premier Mitsubishi 3000GT Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 03-28-2003, 10:55 PM   #1 (permalink)
faz
Forum Member
 
Join Date: Feb 2002
Location: Tennessee
faz is an unknown quantity at this point
Feedback Score: 0 reviews
Default Broken speedometer on 92 VR4

I have recently purchased a 92 VR4 and the speedometer quit working today. The previous owner had it fixed about 8 months ago, he had a new cable and speed sensor replaced at his local dealer for about $200. He also had a kormex transmission installed in the last few months. The odometer is currently working fine, so I was wondering if anyone had any ideas as to what else it could be.

I did a search and saw that some people solved this problem by replacing the instrument cluster, but that was for FWD models and I am not sure if the mechaninsm is the same for the AWD models.

Also, does anyone have any idea as to where the odometer receive its information from? Does it receive its input through the speedometer cable (which would mean that it is still intact) or is there a separate sensor at the wheels? Any help would be greatly appreciated.

fz
faz is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-29-2003, 05:52 AM   #2 (permalink)
Forum Member
 
Stealth92TT's Avatar
 
Join Date: Mar 2003
Location: west linn, oregon
Stealth92TT is an unknown quantity at this point
Feedback Score: 0 reviews
Default

I am not sreu if the odometer and speedometer are run off of the same line, but I don't think if would be abnormal that the odometer still works. If the dealership the previous owner took it to isn't too far away, I would bring it to them and have them fix it, especially if the previous owner gave you the paperwork for it. Otherwise, I am sure the instrumentation for the NA and TT models are the same, probrably just different gear sizes (different calibrations for different wheel size, and the fact that the NA speedo doesnt' go up as high) so those directions should still apply, but from what i heard, you migh thave a hell of a time getting up in there.
__________________



[ Portland - 3S Website ]

[ Email Me ]

[ Portland - 3S Thread ]



Team Insomniacs # 0036

MODS:
K&N Fipk
Greddy Profec B @ 14 PSI
13.1 @ 105 MPH
Stealth92TT is offline   Reply With Quote Quick reply to this message
Old 03-29-2003, 07:59 AM   #3 (permalink)
faz
Forum Member
 
Join Date: Feb 2002
Location: Tennessee
faz is an unknown quantity at this point
Feedback Score: 0 reviews
Default broken speedometer

unfortunately the dealer who did the initial work is located about 800 miles away. The previous owner said that when the speedometer stopped functioning before the odometer stopped working as well. If both the speedometer and odometer receive the information via the same speed sensor in the transmission and speedometer cable, then I guess the problem would lie in the instrument cluster. However, if the speedo and odometer get the information from a different mechanism, it is going to be a little more complicated.
faz is offline   Reply With Quote Quick reply to this message
Old 03-29-2003, 12:19 PM   #4 (permalink)
~Airborne all the way~
 
Lurkers92vr4's Avatar
 
Join Date: Sep 2001
Location: Fort Bragg, NC
Drives: 1992 3000gt vr4
Lurkers92vr4 is an unknown quantity at this point
Feedback Score: 0 reviews
Default

The odometer and speedometer work off the same speed sensor on top of the tranaxle, your problem lies in the cluster.
Your cluster pops out with a few screws, you just got to rotate it the right way to get it out/in but a salvage yard is your best bet, tell them you can remove it yourself (Always made it cheaper for me)
-Jess
__________________
Bo0o
Lurkers92vr4 is offline   Reply With Quote Quick reply to this message
Old 03-29-2003, 01:43 PM   #5 (permalink)
faz
Forum Member
 
Join Date: Feb 2002
Location: Tennessee
faz is an unknown quantity at this point
Feedback Score: 0 reviews
Default

Thanks for the advice Jess. I will take out the cluster this week and look for a replacement.

fz
faz is offline   Reply With Quote Quick reply to this message
Old 04-07-2003, 02:45 PM   #6 (permalink)
Forum Member
 
boffah's Avatar
 
Join Date: Oct 2001
boffah is an unknown quantity at this point
Feedback Score: 0 reviews
Default

say it aint so Faz!?!?

did u trade the 94 base for that?!

does it drive THAT much different??

details on the trade plese, I must track my old baby down

thx, I hope all is well with the fam!

Chris
__________________
boffah is offline   Reply With Quote Quick reply to this message
Old 03-16-2004, 08:34 AM   #7 (permalink)
Verified Seller
 
Join Date: Nov 2000
Location: west palm beach fl
xcelr8 is an unknown quantity at this point
Feedback Score: 13 reviews
Default Re: Broken speedometer on 92 VR4

Quote:
Originally Posted by Lurkers92vr4
The odometer and speedometer work off the same speed sensor on top of the tranaxle, your problem lies in the cluster.
Your cluster pops out with a few screws, you just got to rotate it the right way to get it out/in but a salvage yard is your best bet, tell them you can remove it yourself (Always made it cheaper for me)
-Jess

I hope you guys don't mind me busting in...
I don't think the odometer and speedometer work off the speed sensor. My speedometer doesn't work, but odometer works fine and I replaced the cluster with a known working one. Still doesn't work. Does anyone know if I should replace the speed sensor? It's like 60 and I want to be sure it's that.
Thanks


Dave
__________________


Adapter plates, 14bs, bla bla bla.
Dyno: 481 at crank, est. 370 at wheels.
xcelr8 is offline   Reply With Quote Quick reply to this message
Old 03-17-2004, 01:34 AM   #8 (permalink)
Red Dragon
 
Mad Hatter's Avatar
 
Join Date: May 2002
Location: Zeeland, MI
Drives: Xx6G72+TT=:)xX's mom
Mad Hatter is an unknown quantity at this point
Feedback Score: 3 reviews
Default Re: Broken speedometer on 92 VR4

Quote:
Originally Posted by xcelr8
I hope you guys don't mind me busting in...
I don't think the odometer and speedometer work off the speed sensor. My speedometer doesn't work, but odometer works fine and I replaced the cluster with a known working one. Still doesn't work. Does anyone know if I should replace the speed sensor? It's like 60 and I want to be sure it's that.
Thanks


Dave
They do work off the same sensor, my speed sensor broke a while back, didn't have an odo or MPH gauge. Replaced the sensor and it was fine, both worked again. I got 100miles unrecorded miles now
__________________
Quote:
I'm punching your head as I'm choking you.
1991 3000GT VR4
04' blue and white Gixxer 600 <
2008 Subaru WRX sedan
My VR4 1
My VR4 2
My VR4 3
Mad Hatter is offline   Reply With Quote Quick reply to this message
Old 03-17-2004, 08:29 AM   #9 (permalink)
Verified Seller
 
Join Date: Nov 2000
Location: west palm beach fl
xcelr8 is an unknown quantity at this point
Feedback Score: 13 reviews
Default Re: Broken speedometer on 92 VR4

Quote:
Originally Posted by Mad Hatter
They do work off the same sensor, my speed sensor broke a while back, didn't have an odo or MPH gauge. Replaced the sensor and it was fine, both worked again. I got 100miles unrecorded miles now

I don't know what the hell I was thinking when I posted that.
I'm talking about the tach. lol.

x
xcelr8 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  3000GT/Stealth International Message Center > Modifications and Technical Support > Engine - Turbo

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the 3000GT/Stealth International Message Center forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Free email addresses do not work(yahoo, hotmail, gmail,...)
We are currently being blocked by AOL so any AOL based address may not work(aol.com, aim.com, netscape.net, cs.com)
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 09:04 AM.




Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Search Engine Optimization by vBSEO 3.3.2