Is my ECU Bad? - 3000GT/Stealth International Message Center
3000GT/Stealth International 3000GT/Stealth International
 

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   3000GT/Stealth International Message Center > Automotive Discussions > General

3SI.org is the premier Mitsubishi 3000GT Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 11-13-2012, 04:27 PM   #1 (permalink)
I bet you didn't know!
 
DriveFast99's Avatar
 
Join Date: Jun 2003
DriveFast99 is an unknown quantity at this point
Feedback Score: 8 reviews
Default Is my ECU Bad?

5 have been fighting a mis for some time now. i feel as though I have checked everything i could besides my ECU.

I have replaced the fuel filter, had injectors flow tested, new fuel pump, checked for spark, swapped coil packs, changed plugs and wires twice yet the car still wont accelerate and sounds like a WRX.

The problem is that the car idles pretty well and cruises well once you get up to speed, however getting up to speed is the problem. Under any amount of acceleration the car hesitates, stutters and goes lean. As soon as i let off the throttle the car goes rich quickly then settles back to normal levels. If i have the car cruising it seems fine AFR wise, but just sounds like a WRX and has 0 power.

So i finally pulled the ECU today in hopes to finally figure out my issue. Attached are the pictures of what the board looks like. I'm not very sure of what i should be looking for to tell if its bad or even know how to test it if there is even a way to do so. The board on the top looks normal but the bottom of the board have a small amount of what appears to be rust.

Please take a look and give your input on the ECU or what else might be causing my issues.
Attached Images
File Type: jpg 2012-11-13_16.08.54[1].jpg (105.5 KB, 27 views)
File Type: jpg 2012-11-13_16.09.12[1].jpg (103.5 KB, 20 views)
__________________

15G's/Custom Dual Intakes/IPS FMIC/HKS SSQV/ATR Downpipe/ATR Single Shot/RC 5%0cc Injectors/Hotwired Denso Supra Pump/SX AFPR/SX High Flow Fuel Filter/EK2 Fuel Rail Loop/Vac Reduction/3sx EGR Plates/3SX Plenum Spacer/MSD Wires/NGK R5671A-9/Maft-Pro/HKS EVC-S/AEM Wideband. Boost, Oil Pressue, Water Temp Gauges/Tein S-Tech
DriveFast99 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-13-2012, 07:42 PM   #2 (permalink)
heh
 
coreyb26's Avatar
 
Join Date: Jan 2009
Location: Grantham NH
Drives: 91 Vr4
coreyb26 is an unknown quantity at this point
Feedback Score: 2 reviews
Default Re: Is my ECU Bad?

Your ECU looks just fine. Are you getting a CEL at all?
I suspect you have either a major boost leak or a bad MAF.
coreyb26 is offline   Reply With Quote Quick reply to this message
Old 11-14-2012, 08:44 AM   #3 (permalink)
I bet you didn't know!
 
DriveFast99's Avatar
 
Join Date: Jun 2003
DriveFast99 is an unknown quantity at this point
Feedback Score: 8 reviews
Default Re: Is my ECU Bad?

Quote:
Originally Posted by coreyb26 View Post
Your ECU looks just fine. Are you getting a CEL at all?
I suspect you have either a major boost leak or a bad MAF.
No CEL

I'll check for boost leaks again, but i recently went through and replaced all vac lines again.

I dont have a MAf as i am runnign speed density. i forgot to mention that sorry.
DriveFast99 is offline   Reply With Quote Quick reply to this message
Old 11-14-2012, 09:25 AM   #4 (permalink)
heh
 
coreyb26's Avatar
 
Join Date: Jan 2009
Location: Grantham NH
Drives: 91 Vr4
coreyb26 is an unknown quantity at this point
Feedback Score: 2 reviews
Default Re: Is my ECU Bad?

Might want to look to the speed density setup to make sure everything is right, and still good.
coreyb26 is offline   Reply With Quote Quick reply to this message
Old 11-15-2012, 11:32 PM   #5 (permalink)
user and abuser...
 
bengeeee's Avatar
 
Join Date: Mar 2003
Location: Gaithersburg, MD
Drives: 07 Trailblazer SS
bengeeee is an unknown quantity at this point
Feedback Score: 8 reviews
Default Re: Is my ECU Bad?

I'm no expert but I remembr reading that it will sometimes begin to emit a fishy smell when it goes bad. That might just be for bad capacitors though I don't know. Al those caps look ok to me.

Ben
__________________

92 Sandstone VR4 (Sold),94 Pearl Yellow RT TT (Sold)
94 Red 3000gt VR4 (Sold), 2007 Trailblazer SS (DD)
bengeeee is offline   Reply With Quote Quick reply to this message
Old 11-15-2012, 11:43 PM   #6 (permalink)
U.S. Army Retired
 
ntcmpjg's Avatar
 
Join Date: Apr 2006
Location: Mooresville, NC
Drives: 96 Stealth R/T
ntcmpjg is an unknown quantity at this point
Feedback Score: 25 reviews
Default Re: Is my ECU Bad?

If you see a brownish stain anywhere on the board it could be bad Eric Rymer is the ECU guy.
Email him-rymer@wavecable.com
__________________

3000GT of Europe
www.3sofeu.org/main
Cherry Hill Mitsubishi Coupon Code- 3SE
ntcmpjg is offline   Reply With Quote Quick reply to this message
Old 11-16-2012, 09:48 AM   #7 (permalink)
Keeps fragging heads...
 
2Slow2Tedius's Avatar
 
Join Date: Aug 2003
Location: J-Ville, Florida
Drives: '93 VR-4
2Slow2Tedius is an unknown quantity at this point
Feedback Score: 4 reviews
Default Re: Is my ECU Bad?

When you first turn the key forward, does your CEL come on then go off? It's supposed to. If it DOESN'T, you need an ECU.

Also, unplug your MAF and see if the car runs any different.

When my PTU on the coil pack went bad, my car most definitely sounded like a WRX (I have like 3 extra PTU's if u want me to send you one)
__________________
2Slow2Tedius is offline   Reply With Quote Quick reply to this message
Old 11-16-2012, 12:05 PM   #8 (permalink)
Amature-Crastinator
 
Grandpa Poser's Avatar
 
Join Date: Jun 2012
Location: NE Arkansas
Drives: 95 SOHC, 92 TT
Grandpa Poser is an unknown quantity at this point
Feedback Score: 2 reviews
Default Re: Is my ECU Bad?

An odd longshot might be a plugged or restricted exhaust. Affects topend first, gets bad enough you might get false cel's, egr/02/maf. If it were NA I would say bad vac leak or fuel pressure/volume.

Try the maf thing as mentioned, see if it runs any better default rich.

Luck
__________________
When life throws you a curve......Drive Baby, Drive.
Grandpa Poser is online now   Reply With Quote Quick reply to this message
Old 11-19-2012, 09:42 PM   #9 (permalink)
got boost
 
camaro0281's Avatar
 
Join Date: Nov 2012
Location: indiana
Drives: 91 stealth rt tt
camaro0281 Negative 1
Feedback Score: 4 reviews
Default Re: Is my ECU Bad?

im having same problem... my alternator just died and my battery is dead too. ive heard alternater was culprit if its on its way out.. got one from ebay... hope it works like it did for other people... changed coils. wires. maf. rebuilt both turbos.. pressure washed oil buildup from bad turbo seals in plumbing and flushed intercoolers... pplugged up inter coolers from oil might have same effect. and have a ptu comin from ebay as well... when i turn crank angle sensor, i notice the backfire moves with timing
camaro0281 is offline   Reply With Quote Quick reply to this message
Old 11-19-2012, 09:52 PM   #10 (permalink)
Amature-Crastinator
 
Grandpa Poser's Avatar
 
Join Date: Jun 2012
Location: NE Arkansas
Drives: 95 SOHC, 92 TT
Grandpa Poser is an unknown quantity at this point
Feedback Score: 2 reviews
Default Re: Is my ECU Bad?

Kind of forgot a bad battery can make these cars run like s***.
Grandpa Poser is online now   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  3000GT/Stealth International Message Center > Automotive Discussions > General

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the 3000GT/Stealth International Message Center forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Free email addresses do not work(yahoo, hotmail, gmail,...)
We are currently being blocked by AOL so any AOL based address may not work(aol.com, aim.com, netscape.net, cs.com)
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 11:32 PM.




Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Search Engine Optimization by vBSEO 3.3.2