Heater giveing me problems - 3000GT/Stealth International Message Center
3000GT/Stealth International 3000GT/Stealth International
 

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   3000GT/Stealth International Message Center > Automotive Discussions > General

3SI.org is the premier Mitsubishi 3000GT Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 01-25-2013, 06:37 PM   #1 (permalink)
Forum Member
 
DEMOSES NY's Avatar
 
Join Date: Dec 2012
Location: Long Island, N.Y
Drives: 95' 3000gt 99' vr4
DEMOSES NY is an unknown quantity at this point
Feedback Score: 4 reviews
Mitsubishi Heater giveing me problems

Today after warming up my car i noticed that the heater blower stopped working... at first i thought it was probably a fuse but 10 minutes later i tried again and it worked... heater was working fine until it just shut down again.....this process keeps happening and i have no idea what the problem could be?? Today is first time Ive had this issue.... any theory's, information or answers would be greatly appreciated...ERIK
DEMOSES NY is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-25-2013, 07:38 PM   #2 (permalink)
ATOLDASO
 
Hard AttacK's Avatar
 
Join Date: Jun 2008
Location: penn PA
Drives: 91 Stealth TT
Hard AttacK is an unknown quantity at this point
Feedback Score: 21 reviews
Default Re: Heater giveing me problems

i would check for voltage at the blower when it stops. If its getting voltage then I would say bad blower motor. Does it work on any setting hi or low?
__________________
Quote:
Originally Posted by fastnelson View Post
went over 250 one time

NBF
Quote:
Originally Posted by gatecrasher
DSM owner = king of how fast can i go for $26.
91tt-money bitch
92tt-daily bitch
Hard AttacK is offline   Reply With Quote Quick reply to this message
Old 01-25-2013, 07:56 PM   #3 (permalink)
Forum Member
 
DEMOSES NY's Avatar
 
Join Date: Dec 2012
Location: Long Island, N.Y
Drives: 95' 3000gt 99' vr4
DEMOSES NY is an unknown quantity at this point
Feedback Score: 4 reviews
Default Re: Heater giveing me problems

Once it shuts down it doesnt work on any setting... the few times i messed with it , heater came back on after about 10-15 minutes... but only ran for limited time before it shut down... thanks for responding... this problem is killing me its hard to drive with glass fogging up....
DEMOSES NY is offline   Reply With Quote Quick reply to this message
Old 01-25-2013, 08:30 PM   #4 (permalink)
ATOLDASO
 
Hard AttacK's Avatar
 
Join Date: Jun 2008
Location: penn PA
Drives: 91 Stealth TT
Hard AttacK is an unknown quantity at this point
Feedback Score: 21 reviews
Default Re: Heater giveing me problems

I would check voltage like I said. I bet its seizing or has corrosion on the electronics.
Hard AttacK is offline   Reply With Quote Quick reply to this message
Old 01-26-2013, 01:29 AM   #5 (permalink)
Wheee! 2 wheels is fun!
 
speedy25's Avatar
 
Join Date: Dec 2006
Location: NE oHIo
Drives: Various Japanese
speedy25 Level 1speedy25 Level 1speedy25 Level 1
Feedback Score: 7 reviews
Default Re: Heater giveing me problems

Most likely worn out blower motor, OR duct plugged with debris. Its worth your while to pull it and check.

-SP
speedy25 is offline   Reply With Quote Quick reply to this message
Old 01-28-2013, 01:10 AM   #6 (permalink)
Asks Dumb Questions
 
93Driver's Avatar
 
Join Date: Jan 2013
Location: metro Portland, OR
Drives: 1993 3000gt SL 5spd
93Driver is an unknown quantity at this point
Feedback Score: 1 reviews
Default Re: Heater giveing me problems

Was the blower motor on mine, so suggest checking that first.
93Driver is offline   Reply With Quote Quick reply to this message
Old 01-28-2013, 07:37 AM   #7 (permalink)
Forum Member
 
Join Date: Dec 2012
NeStealth94rt is an unknown quantity at this point
Feedback Score: 4 reviews
Default Heater giveing me problems

Any how to's on how to replace it? Mine just started this yesterday :/


Sent from AutoGuide.com App
NeStealth94rt is offline   Reply With Quote Quick reply to this message
Old 01-28-2013, 12:31 PM   #8 (permalink)
Forum Member
 
Join Date: Dec 2012
NeStealth94rt is an unknown quantity at this point
Feedback Score: 4 reviews
Default Heater giveing me problems

Nevermind, was way easier then on my old car


Sent from AutoGuide.com App
NeStealth94rt is offline   Reply With Quote Quick reply to this message
Old 01-28-2013, 07:27 PM   #9 (permalink)
Asks Dumb Questions
 
93Driver's Avatar
 
Join Date: Jan 2013
Location: metro Portland, OR
Drives: 1993 3000gt SL 5spd
93Driver is an unknown quantity at this point
Feedback Score: 1 reviews
Default Re: Heater giveing me problems

Just in case you change your mind on the *nevermind*:

Blower motor not working, need advice

Good pics & instructions there.
__________________
Bigger isn't always Better
ECU Compatibility Info
14yr owner of a stock '93 3000gt SL 5spd
2013 replaced: Coils, ECU caps (Steve), PTU, IAC || 2014: ECS & needs paint
Hates: cold, rain, ice, snow, red lights
Loves: hot sticky pavement, banked corners, downshifting, fresh oil changes, brand new tires
Latest Addiction: CntrlSwitch Vids
93Driver is offline   Reply With Quote Quick reply to this message
Old 01-29-2013, 06:51 AM   #10 (permalink)
Forum Member
 
Join Date: Dec 2012
NeStealth94rt is an unknown quantity at this point
Feedback Score: 4 reviews
Default Heater giveing me problems

I will definitely save that just in case, but I went to the graveyard and pulled a blower motor for 10$ and it fixed my problem! Thanks though


Sent from AutoGuide.com App
NeStealth94rt is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  3000GT/Stealth International Message Center > Automotive Discussions > General

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the 3000GT/Stealth International Message Center forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Free email addresses do not work(yahoo, hotmail, gmail,...)
We are currently being blocked by AOL so any AOL based address may not work(aol.com, aim.com, netscape.net, cs.com)
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 03:06 AM.




Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Search Engine Optimization by vBSEO 3.3.2