Another no start thread - 3000GT/Stealth International Message Center
3000GT/Stealth International 3000GT/Stealth International
 

Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   3000GT/Stealth International Message Center > Automotive Discussions > General

3SI.org is the premier Mitsubishi 3000GT Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools
Old 01-23-2013, 02:46 PM   #1 (permalink)
Forum Member
 
Join Date: Sep 2012
Location: Sierra vista az
Drives: 92 stealth tt
Keo92stealth is an unknown quantity at this point
Feedback Score: 4 reviews
Default Another no start thread

Alright my father and I spent the past 5 days putting this thing back together. You go to start it and all it does is crank . We already looked over the basics . Its got spark , timing is correct for sure !! But I'm still not sure about the fuel part . Whenever I turn the key the fuel pressure goes up then it goes to zero . Maybe a problem ?the spark plugs aren't wet either . The entire fuel system is new . Every piece . Could the e85 have swelled the injectors causing them not to work ?? Also might have another problem . My arc2 isn't lighting up when I turn the lights on.
Keo92stealth is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-23-2013, 03:24 PM   #2 (permalink)
Verified Seller
 
westcott's Avatar
 
Join Date: Feb 2008
Location: South of Houston
Drives: 1991 Stealth ES
westcott is an unknown quantity at this point
Feedback Score: 14 reviews
Default Re: Another no start thread

Quote:
Originally Posted by Keo92stealth View Post
Alright my father and I spent the past 5 days putting this thing back together. You go to start it and all it does is crank . We already looked over the basics . Its got spark , timing is correct for sure !! But I'm still not sure about the fuel part . Whenever I turn the key the fuel pressure goes up then it goes to zero . Maybe a problem ?the spark plugs aren't wet either . The entire fuel system is new . Every piece . Could the e85 have swelled the injectors causing them not to work ?? Also might have another problem . My arc2 isn't lighting up when I turn the lights on.
Do you have a data logger?
How did you plan to tune your engine for E85?
What fuel pressure regulator are you using?
I would start with trouble shooting the ARC2. I would start here.

http://www.stealth316.com/2-arc2tuning.htm
__________________


Original Owner, ROTM-March 2013, ROTY 2013, Highest WHP N/A 2013, TXG13 3S Sponsor
My mod list can be found in My Garage
westcott is offline   Reply With Quote Quick reply to this message
Old 01-23-2013, 03:39 PM   #3 (permalink)
Forum Member
 
Join Date: Sep 2012
Location: Sierra vista az
Drives: 92 stealth tt
Keo92stealth is an unknown quantity at this point
Feedback Score: 4 reviews
Default Re: Another no start thread

Have a scanmaster. I'm going to check the wiring on the arc2 now. Then solder them . The fpr is a fuel lab.
Keo92stealth is offline   Reply With Quote Quick reply to this message
Old 01-23-2013, 03:45 PM   #4 (permalink)
Verified Seller
 
sweet91's Avatar
 
Join Date: Dec 2004
Location: Herriman, UT
Drives: 95' VR4
sweet91 is an unknown quantity at this point
Feedback Score: 5 reviews
Default Re: Another no start thread

I would also list the mods you have done to the car. Its always nice to know what has been done to the car when figuring out whats wrong.
sweet91 is offline   Reply With Quote Quick reply to this message
Old 01-23-2013, 03:46 PM   #5 (permalink)
Verified Seller
 
westcott's Avatar
 
Join Date: Feb 2008
Location: South of Houston
Drives: 1991 Stealth ES
westcott is an unknown quantity at this point
Feedback Score: 14 reviews
Default Re: Another no start thread

Quote:
Originally Posted by Keo92stealth View Post
Have a scanmaster. I'm going to check the wiring on the arc2 now. Then solder them . The fpr is a fuel lab.
Will you be monitoring EGT?
westcott is offline   Reply With Quote Quick reply to this message
Old 01-23-2013, 04:58 PM   #6 (permalink)
Forum Member
 
Join Date: Sep 2012
Location: Sierra vista az
Drives: 92 stealth tt
Keo92stealth is an unknown quantity at this point
Feedback Score: 4 reviews
Default Re: Another no start thread

Ross 9 to 1 pistons
H beam rods with arp bolts
Forged crank
Ported head with brian crower 1mm over intake and exhaust
Brian crower valve springs
Oem headgaskets
Arp headstuds
T3 hybrid turbos with .63ar
Tial leaded fuel wastegates with 1bar springs
Cx racing fmic
Arc2 in blowthru
950cc delphis on e85
Jackhammer fuel hanger holding 2 walbros 255
Fuel lab fpr
Aeromotive fuel filter
Entire fuel system done in ptfe braided black lines
Beefed up oil cooler
Gates racing belt
Ninja performance soild tension setup
3sx single pass radiator
Tial q blowoff
Scanmaster
Aem twin fire
3sx fuel rails
And so on....
Keo92stealth is offline   Reply With Quote Quick reply to this message
Old 01-23-2013, 05:03 PM   #7 (permalink)
Forum Member
 
Join Date: Sep 2012
Location: Sierra vista az
Drives: 92 stealth tt
Keo92stealth is an unknown quantity at this point
Feedback Score: 4 reviews
Default Re: Another no start thread

Quote:
Originally Posted by westcott View Post
Will you be monitoring EGT?
probably not
Keo92stealth is offline   Reply With Quote Quick reply to this message
Old 01-23-2013, 07:51 PM   #8 (permalink)
Amature-Crastinator
 
Grandpa Poser's Avatar
 
Join Date: Jun 2012
Location: NE Arkansas
Drives: 95 SOHC, 92 TT
Grandpa Poser is an unknown quantity at this point
Feedback Score: 1 reviews
Default Re: Another no start thread

Bet you did but gotta ask, try starting on spray cleaner?
Do you have a NOID to confirm injector signal?
Visually confirm correct cam placement? Looking down the fill hole the lobes you see should point almost straight up and slightly towards each other on the DOHC.

luck
__________________
When life throws you a curve......Drive Baby, Drive.
Grandpa Poser is online now   Reply With Quote Quick reply to this message
Old 01-23-2013, 08:53 PM   #9 (permalink)
Forum Member
 
Join Date: Sep 2012
Location: Sierra vista az
Drives: 92 stealth tt
Keo92stealth is an unknown quantity at this point
Feedback Score: 4 reviews
Default Re: Another no start thread

Tried the fluid. It turned over for a brief second them died. How do I check to see if the injectors are spraying. After all that cranking and cranking the spark plugs should be wet. But they are not. Wounder why?
Keo92stealth is offline   Reply With Quote Quick reply to this message
Old 01-23-2013, 10:06 PM   #10 (permalink)
Verified Seller
 
westcott's Avatar
 
Join Date: Feb 2008
Location: South of Houston
Drives: 1991 Stealth ES
westcott is an unknown quantity at this point
Feedback Score: 14 reviews
Default Re: Another no start thread

Quote:
Originally Posted by Keo92stealth View Post
Tried the fluid. It turned over for a brief second them died. How do I check to see if the injectors are spraying. After all that cranking and cranking the spark plugs should be wet. But they are not. Wounder why?
I take it you are getting fuel to the rails and your fuel pressure is constant?

Has to be the ECU or ARC not sending a signal to the injectors.

Check the service manual to verify what signal you should be getting at the injectors and let us know.

3SX Performance - Service Manuals Backups 3000GT / Stealth*-*Mitsubishi 3000GT*/*Dodge Stealth Parts
westcott is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  3000GT/Stealth International Message Center > Automotive Discussions > General

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the 3000GT/Stealth International Message Center forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Free email addresses do not work(yahoo, hotmail, gmail,...)
We are currently being blocked by AOL so any AOL based address may not work(aol.com, aim.com, netscape.net, cs.com)
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 08:09 AM.




Garage Plus vBulletin Plugins by Drive Thru Online, Inc.

Search Engine Optimization by vBSEO 3.3.2